Vai al contenuto

  • Connettiti con Facebook Log In with Google      Connettiti   
  • Registrati

Foto
- - - - -

Vista E Xp Dual Boot


  • Per cortesia connettiti per rispondere
70 risposte a questa discussione

#31 amundsen

amundsen

    Newbie

  • Members
  • Stelletta
  • 2 messaggi

Inviato 18 aprile 2007 - 03:49

ho seguito le istruzioni per creare il dual boot tra vista e xp.
Vista era pre-installato sul notebook in C
Nella partizione D (formattata in NFTS) ho invece installato XP pro.
Dopo l'installazione di XP il computer avviava regolarmente XP e ho potuto installare tutti i driver del mio ACER Travelmate 5623 (funzionava tutto perfettamente).
Ho ripristinato l'avvio di Vista con il Cd rom in dotazione e il computer si riavvia con Vista senza più riconoscere XP.

In Vista, dal prompt di dos (accesso come aministratore) ho editato i seguenti comandi:
C:\Windows\system32\Bcdedit -create {ntldr} -d "WindowsXP" C:\Windows\system32\Bcdedit -set {ntldr} device partition=d: C:\Windows\system32\Bcdedit -set {ntldr} path \ntldr C:\Windows\system32\Bcdedit -displayorder {ntldr} -addlast

ho confermato il comando ma mi appare il seguente messaggio:

"E' necessario specificare una descrizione per la nuova voce.
Eseguire"bcdedit /?" per viualizzare le informazioni della Guida della riga di comando"

qualcuno può aiutarmi???

#32 netquik

netquik

    Tweakness Admin

  • Admin
  • 3.827 messaggi

Inviato 18 aprile 2007 - 04:45

Ciao amudsen

i comandi li esegui in ordine e non tutti insieme?

C:\Windows\system32\Bcdedit -create {ntldr} -d “Windows XP”

C:\Windows\system32\Bcdedit -set {ntldr} device partition=d:

C:\Windows\system32\Bcdedit -set {ntldr} path \ntldr

C:\Windows\system32\Bcdedit -displayorder {ntldr} -addlast




per gio.mitico

ciao la tua situazione è diversa da quella descritta in questo thread... perchè tu avevi XP installato e poi hai installato Vista in una partizione secondaria...

ora... se non riesci ad usare EasyBCD... ti consigli di avviare con il DVD di Vista e procedere alla riparazione dell'avvio di Vista.. dovrebbe ripristinarti il bootmanager rconsocendo XP...

#33 gio.mitico

gio.mitico

    Newbie

  • Members
  • Stelletta
  • 4 messaggi

Inviato 18 aprile 2007 - 06:58

forse il problema e la versione che ho di Vista xchè facendo partire all'avvio il disco , va in lettura ma nn fa nulla ... passa diretto ad xp :( :muro:

#34 amundsen

amundsen

    Newbie

  • Members
  • Stelletta
  • 2 messaggi

Inviato 19 aprile 2007 - 07:58

Caro NetquiK
grazie per il suggerimento.
Sbagliavo digitando gli ordini con Bcdedit tutti insieme senza confermare ma ciò era dovuto al fatto che la prima volta, dopo aver digitato la riga di comando
Bcdedit -create {ntldr} -d "WindowsXP"
il prompt mi rispondeva
Errore durante l'esecuzione dell'operazione di creazione specificata. La voce specificata esiste già
Ho rieditato i successivi ordini uno per volta e le operazioni sono state concluse.
:huh:
Al riavvio del computer è comparso il dual boot ma quando selezionavo l'opzione di avvio di una precedente versione di Windows a Vista mi compariva il seguente messaggio di errore:
File \ntldr
stato: 0xc000000f
impossibile caricare la voce selezionata. Applicazione danneggiata o mancante

:angry:
sono stato ad impazzire e alla fine, rileggendomi i precedenti messaggi ho tentato sostituendo a D: il device partition in cui è allocato XP con C:
Stranezze dell'informatica!!!
Tutto ora funziona. Ho perso non so perchè alcuni driver in XP che proverò a reinstallare ma sembra che vada bene: con il dual boot riesco a lanciare sia Vista in C: come sistema predefinito sia XP in D:
di nuovo grazie e spero che forse anche altri sostituendo l'indicazione del device partition di XP risolvano forse i loro problemi

#35 D2_WON

D2_WON

    Newbie

  • Members
  • Stelletta
  • 1 messaggi

Inviato 20 aprile 2007 - 09:52

Ho un problema... e leggendo questo 3d purtroppo non riesco a risolvere...

vediamo se riesco a spiegarmi bene...

Avevo Windows Vista su un HD ma avevo bisogno di Xp e allora ho seguito i consigli di questo 3d e ho comprato un HS sata per installarmi un bel Xp...

Ho installato Xp ho installato i driver video blabla... ho riavviato e mi è partito automaticamente vista... mi è parso strano perchè dicevate che vista non partiva +... allora ho usato easyBCD ho creato il boot manager bellino bellino... Xp + Vista vo a riavviare il Pc mi viene la schermata del boot manager e Vista me lo fa scegliere bene.... ma quando seleziono XP mi parte il caricamento ma mi da l'errore sul Boot (chiaramente perchè non ho fatto nulla per sistemarli i boot differenti)

cmq... l'errore che mi da è:

File Boot.ini NON VALIDO
Avvio di c:\windows\ in corso...

Ho Xp nel disco d:\
e Vista c:\

Sapete dirmi la soluzione vi ringrazio in anticipo...

#36 Ariuz

Ariuz

    Newbie

  • Members
  • Stelletta
  • 4 messaggi

Inviato 13 maggio 2007 - 08:43

ciao gio io ho il tuo stesso identico problema e nn riesco a fare nulla!! + che altro ho provato a ripristinare l'mbr di vista ma al riavvio vista nn parte proprio! tu hai risolto per caso?? aiutooooo!

#37 netquik

netquik

    Tweakness Admin

  • Admin
  • 3.827 messaggi

Inviato 14 maggio 2007 - 01:36

ciao ragazzi avete provato ad usare l'ultima versione di easyBCD?

dovrbbe aver integrato una funzione di diagnostica e riparazione

#38 Ariuz

Ariuz

    Newbie

  • Members
  • Stelletta
  • 4 messaggi

Inviato 14 maggio 2007 - 03:57

quel programma ssi usa solo da vista io seguo il procedimento come gio ma nn riesco a riattivare vista per poi andarci e da vista sistemare il boot con easybcd cosi da far ripartire il boot con entrambi correttamente! putroppo da xp facendo: drive:\boot\Bootsect.exe -NT60 All su C: mi dice accesso negato mentre sulle altre partizioni compresa quella dove c'è vista mi dice che è stato ripristinato crrettamente!! poi quando riavvio vista nn parte!! caput? quindi nn so che fare e sto chiedendo aiuto il mio prob come dicevo è lo stesso identico di GIO!

#39 netquik

netquik

    Tweakness Admin

  • Admin
  • 3.827 messaggi

Inviato 14 maggio 2007 - 10:28

CIao ariuz

EasyBCD dovrebbe funzionare anche da XP

Se lo installi prova ad anadare in Manage Bootloader

ed a fare Reinstall Vista Bootloader


in alternativa come detto potresti provare ad avviare con il DVD di Vista e procedere alla riparazione dell'avvio di Vista.. dovrebbe ripristinarti il bootmanager rconsocendo XP...

#40 Ariuz

Ariuz

    Newbie

  • Members
  • Stelletta
  • 4 messaggi

Inviato 14 maggio 2007 - 08:29

ciao netquik allora io ho provato a rimettere easybcd ma all'avvio mi da un errore che dice ERROR: no valid entries found! gli dico OK e poi si apre il programma! vado su Manage Bootloader e metto Reinstall the Vista Bootloader faccio Write e sotto mi scrive: the MBR is re-written! restart! ma nn succede nulla! Vista è come se nn ci fosse porca miseria! che posso fare?

#41 netquik

netquik

    Tweakness Admin

  • Admin
  • 3.827 messaggi

Inviato 15 maggio 2007 - 01:53

ciao

hai provato ad eseguire la riparazione del boot di vista avviando da DVD?

#42 syriodragon

syriodragon

    Newbie

  • Members
  • Stelletta
  • 6 messaggi

Inviato 16 maggio 2007 - 02:26

:blink: ciao ho seguito attentamente la discussione sul forum e dopo 3 giorni di impazzimento ancora non sono riuscito a combinare granchè..
vi descrivo la mia situazione:
Ho comprato un asus con vista preinstallato su c: ,e ho montato xp sulla partizione d:
da qui ho provato a fare come dicevate ma non sono riuscito in quanto mi blocco al passo 1 :
da xp lancio dal prompt : Drive:\boot\ Bootsect.exe –NT60 All per ripristinare il mbr di vista ma non so xche ma io questo file in questa cartella non ce l'ho e una ricerca non trova nulla.. quindi non posso procedere..Ho provato anche con l'easyBCD con l'opzione reistalla il bootloader ma niente da fare..
Ho quindi fato il recover con il cd asus su c:
questa operazione però ha cancellato tutti i file che xp aveva messo nella partizione attiva (c:) e quindi sembra una gara tra vista e xp...
ora parte solo vista in quanto da xp mi dice che manca il file \ntldr (ovviamente camcellato) dalla reinstallazie di vista..
Ho provato ad inserirlo manualmente (dal cd di xp è presente) in c: ma niente da fare non da segno di vita...
help...

#43 netquik

netquik

    Tweakness Admin

  • Admin
  • 3.827 messaggi

Inviato 16 maggio 2007 - 03:51

CIao

hai riprovato con l'ultimo easyBCD da vista?

eventualmente anche a fare un diagnostica?

ciao prova ad eseguire da un prompt dei comandi di amministratore

bcdedit /enum

e riporta i risultati

#44 syriodragon

syriodragon

    Newbie

  • Members
  • Stelletta
  • 6 messaggi

Inviato 16 maggio 2007 - 05:43

La versione è 1.6 di easy ma comunque non capisco perchè non mi trova il file bootsect.exe..
Forse è la versione di vista rilasciata alla asus xo bho mi sa strano..
com il comando dal primpt genera questo : nell allegato... :ph34r:

Allega File(s)



#45 syriodragon

syriodragon

    Newbie

  • Members
  • Stelletta
  • 6 messaggi

Inviato 16 maggio 2007 - 05:46

:unsure: dato che è abbastanza illeggibile l'allegato in formato di notepad te lo mado via txt che è sempre il migliore..

Allega File(s)






0 utente(i) stanno leggendo questa discussione

0 utenti, 0 ospiti, 0 utenti anonimi